Share Sites

Need help? You've come to the right place!

This is a public Forum  public


    Pam Corey
    Can't save to camera roll
    Topic posted September 20, 2013 by Pam CoreyNovice 
    4863 Views, 7 Comments
    Can't save to camera roll
    With iOs 7 app is not the same
    Is there going to be an upgrade to the app? I like to save photos from my Shutterfly albums to my phone and this function has disappeared!</p>



    • Shannon

      Please note these instructions are for Shutterfly for iPhone.

      -First you need to make sure your Shutterfly app is on under Settings, Privacy, Photos.

      -Open your Shutterfly app, tap the picture you want to save back to your camera roll. Depending on your internet connection your phone has (where you are matters!) you may find it is slow to load the picture completely. If you can, connect to WiFi first. 

      -Once the picture is loaded, tap the picture and look in the lower left corner. Tap the icon that looks like an arrow pointing right. 
      Tap the Save Image option in the lower left corner. 

      -Once you do this, the picture saves to your camera roll. (There won't be a message indicating the photo was saved.) Go to your camera roll to see saved picture.

    • Sima Nadler

      I'm having the same problem.  The solution suggested above did not help.

      Settings->Privacy-Photos is on

      When I try to save a picture to camera roll (tap icon that looks like an arrrow pointing right) there is no option to "Save Image" only to email, copy, etc.

      In the view where multiple images can be chosen the option to save to camera roll is greyed out and doesn't work. (I tried)

      Please help!


    • Shannon

      Hi Sima,

      Are you on your iphone app or the ipad app?

    • Shannon

      There seems to be a step missing. While in the app, click Upload. That should prompt you to allow access to the app. Once that is done, then follow the instructions to save a photo. Please post a screenshot of the screen where "save image" is missing, if you're still having trouble

      • anthony young

        Thank you for posting.  I was working on this for an hour or more.  Definately a bug in the installation process.  I deleted and reinstalled the shutterfly app and in never prompted me for access to my photos and it doesn't appear in the "privacy" option either.

        Thanks again


    • Sima Nadler

      Hi Shannon,

      In answer to your first question, I'm on my iPhone.

      And, you second post solved the problem! Thanks.

      It appears that even though in Settings->Privacy it showed that Shutterfly had access to my photos, it evidently did not.  Once I tried to upload photos as you suggested, it prompted me to allow Shutterfly to access my photos.  Once I did my issue was solved for downloading photos as well.

      Not sure if this is a Shutterfly or iOS 7 bug, but whatever the case ... thanks for the prompt response!


    • Joseph Serrano

      Troubleshooting steps if you cannot save to the camera roll on the iPhone.

      Part 1: Go to phone Settings==> Privacy==> Photos, then turn on Shutterfly

      If this does not work then go on to part 2.

      Part 2: Then for the next step you will need to go to Settings==>General==> Reset, then reset her privacy and location. This will reset any app that has access to her privacy and location. Once she has done this, restart the phone, then go back to the app , and try to upload. It should ask if you want to give Access to photos, you will have to hit that, and then you should be able to save to the camera roll.